Mercury Cougar Owners banner

1 - 5 of 5 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter #1
I put a 97 ford explorer rear end in my 67 cougar. I replaced the the leaf springs from laurel mustang. I also put on 3 inch lowering blocks because the car was a 4 inch height difference in the front/back. My problem is....my driver side wheel is 2.0 inches from the front quarter and 3 inches from the rear quarter. My passenger side wheel is 1.5 inches from the front quarter and 4 inches from the rear quarter. STUMPED!!!!!! ?????? is all I got to say. Any ideas?
 

·
Registered
Joined
·
321 Posts
Assuming the rearend is square in the car (was the other one?). Do the springs have the locator pin in the correct spot? Maybe it's had a quarter panel put on it at some point??
 

·
Registered
Joined
·
92 Posts
Discussion Starter #3
Well looking at it tonight, it looks like the leaf spring shackle is getting caught up or the leaf is too strong. I can put my finger through the space between the shackle and body on the driver side, but can not do it on the passenger side. I am going to start with this issue. My question is now, I bought the spring from laurel mountain mustang. It states online it will fit 67-73 cougars. HOWEVER, both MU and WCCC states that the springs are vehicle specific (with ac, no ac, power steering).......what are your thoughts?
 

·
Registered
Joined
·
92 Posts
Discussion Starter #5
Bought 2 new springs....put them on...had the same problem...stood in the trunk, shackles straightened out, tightened the bolts...now everything is fixed! The springs had the same part number on it that I got. Already spent the money, so I kept them on. Measurements were the same. I got the measurements offline. So, all went well!
 
1 - 5 of 5 Posts
Top