Mercury Cougar Owners banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
Couple days ago turn signals stopped working. No clicking, no green lights on dashboard, no bulbs light up. Turn switch does engage, stays in "turning" mode (up or down) till steering wheel will switch it off back to regular position.

Emergency button on top of steering column does work - all yellow bulbs light up, both green lights on dashboard also.

Today I took apart switch assembly in steering column, but with no result - all contacts look ok, no mechanical damage, no dirt on the way of electrical contacts.

Could it be flasher relay? Turn signals relay(if any different)? I googled flasher relay and found two different relays - one square and other is "can" like. Which is the right one?
If it is relay, where is it located? I read that it's in some other place than fuses, nor is it under the hood.

Any info would be appreciated.

UPDATE: all worked fine after 1 hour. I'm puzzled, could it be some kind of link overheating? or maybe that relay again?
 

·
Registered
Joined
·
4 Posts
I've got a 93, looking at mine, there's a master fuse panel under the hood on the driver's side just to the rear of the battery.

Check the flasher relay in there, considering the hazard lights went.

Also, FYI, a good place for the 89-97 cougar info is on tccoa.com for the later model cougars.
 

·
Registered
Joined
·
2,493 Posts
on my 90 SC, the flasher is a square unit, to the right of the steering column, under the dash.
what he said, and tccoa.com is a better avenue for this model
 
1 - 4 of 4 Posts
Top