Mercury Cougar Owners banner

1 - 7 of 7 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter #1
My 68 cougar is having problems with the turn signals. Sometimes they work, but when they do its no longer than about 10 seconds average. When I say they are having problems I mean they dont work at all. I replaced the original mess in the trunk with a solid state system. It is hooked up correctly. The hazards work perfectly, but when I put the turn signal lever up or down SOMETIMES it works for 10 seconds then dies and most of the time it doesnt work at all. Im stuck and dont know where to turn, and would like to get this fixed. Also When the turn signals worked only the middle light on the tail lights worked. The other bulbs are fine as well as the sockets. This happened before I installed the solid state system and it was still only the middle light when I installed the solid state system. Much appreciated!!!

Nate B
 

·
Registered
Joined
·
1,853 Posts
I think I will book mark this for future reference too. Thanks.
 

·
Registered
Joined
·
45 Posts
Not related to NO lights working, but if my emergency flasher switch is partially depressed, I get BOTH rear lights to sequence no matter if I signal left or right. Found this out when a fellow motorist commented on my turn signals, but stated I should make myself more clear when signaling!
 

·
Registered
Joined
·
396 Posts
There is also a curcuit breaker located on drivers side rear mounted up in the rear most corner of the rear about same level as tail lights. If it goes, then the tail lights won't work. Could test that unit by bypassing it ans see if the lights work then. I don't think this is something that is replaced with all upgrade kits and can be a real pain in the a$$. They are on the expensive side to replace when they are available, around $50-60. Hope this helps.
 
1 - 7 of 7 Posts
Top