Mercury Cougar Owners banner

1 - 12 of 12 Posts

·
Registered
Joined
·
269 Posts
Discussion Starter #1
The brake lights and hazard lights work. The left indicator always work. The right indicator works about half the time with the lights off and hardly ever with the lights on. The sequencer has the original shell, but apparently had the motor replaced with an electronic unit about 20 years ago.

Do the electronic sequencers go bad over time like the electrical motor ones ? or is this more likely to caused by something else ?

Martin
 

·
Registered
Joined
·
433 Posts
I thought the 69's had a solid-state sequencer from the factory rather than the motor driven cam setup of the 67-68 models.
 

·
Registered
Joined
·
889 Posts
try this first

Before I would start replcing things go through and check ALL the grounds.It sounds like your not getting enough.I had alot of (dimming lights) on my unit when I got it.It took a little time but I did find some corroded grounding leads.Worth a look then you will know what to replace and what not to.
 

·
Banned
Joined
·
4,754 Posts
Go to cougars unlimited home page and look thru Vic's troubleshooting guide. He's the cat.
 

·
Registered
Joined
·
269 Posts
Discussion Starter #5
Thanks for the referal to Cougars Unlimited. I have checked the grounds, light bulps, polished the light sockets where the connect to the light housing. The right side still works intermittenly. Given that the car is a keeper for life I will order the sequencer. If I don't need it now I will later.

Thanks to all who have offered advice.
 

·
Registered
Joined
·
269 Posts
Discussion Starter #6
FYI

I installed the new sequencer and flashcan last night and now have fully functioning turn signals again. Thanks again for the advice.
 

·
Banned
Joined
·
4,754 Posts
Martin Thats Grrreat news. How much was the can and sequencer and did ya get em from Vic?:)
 

·
Registered
Joined
·
269 Posts
Discussion Starter #8
$90 + $11 shipping from John's Classic Cougars. I got a few other items at the same time.
 

·
Registered
Joined
·
1,163 Posts
I have changes sequencer & can. Sequences to right but not left. The left runs as a single unit. I think sometine in the past it has been spliced to one lead rather than individual for each light. This based upon evidence of being smacked on left rear and some splices outside harness in trunk. I have diagram and plan to take harness apart this weekend and find problem. Prior to sequencer and can nothing sequenced.
 

·
Banned
Joined
·
4,754 Posts
Jim Be sure to solder all connections and shrink wrap as well once you have it apart. Catzya Ray
 

·
Registered
Joined
·
1,163 Posts
I have been using crimp fittings and sealing with liquid tape then taping. The liquid tape seals so no moisture can get to connection. I would have no problem with soldering though. I may do it on these and use liquid tape on srink tube.

Thanks.
 

·
Banned
Joined
·
4,754 Posts
Sounds good . Those crimp ons will give out after a while when you least expect it. Being as yours is an E cat a "professional" look is achieved with solder and shrink wrap plus solder only comes undone if heated. Quality Cat quality repair. Catzya:)
 
1 - 12 of 12 Posts
Top