Mercury Cougar Owners banner

1 - 10 of 10 Posts

·
Registered
Joined
·
866 Posts
Discussion Starter #1
Hey guys, I have a question for you all. My left turn signal will flash normally, but when I put on the right side, the light on the dash will stay lit solid, but none of the lights out side the car that should be flashing are lit. I did check all of the bulbs, and they all work.

Any ideas?

Thanks

Chris
 

·
Registered
Joined
·
433 Posts
No suggestions here...on mine, the left ones seem to work but when you hit the right ones, one of the left ones comes on and stays on. Also the interior indicators don't work. I am leaning towards the switch since the sequencer seems to work.
 

·
Premium Member
Joined
·
3,404 Posts
It could be one of the bulbs isnt getting a good ground. If the light on the dash stays on, its a shorted out bulb somewhere.

Rick
 

·
Registered
Joined
·
866 Posts
Discussion Starter #4
Yeah, but all of the bulbs light up when I turn the marker lights on or brake lights.
 

·
Registered
Joined
·
866 Posts
Discussion Starter #5
I just remembered something... there are two lights per bulb, maybe the turn signal portion of the bulb is not grounded? :confused:
 

·
Premium Member
Joined
·
3,404 Posts
Chris, do all the lights lite up. The front, sides, back. I find if the dash light goes on but doesnt blink, then its a bulb. :confused:
 

·
Registered
Joined
·
866 Posts
Discussion Starter #7
Yeah, all the lights do light up, but maybe the blinker part of the bulb is burned out on one of the bulbs?

Thanks

Chris
 

·
Registered
Joined
·
3,141 Posts
Replace the flasher. :)
 

·
Registered
Joined
·
866 Posts
Discussion Starter #10
Thanks Bruter, I forgot about that page! And I even have it bookmarked lol. I just now noticed that when I turn that side on the rear three lights stay solid (I had my friend look yesterday, obviously he's blind, because he told me none of them were going on, must have been the sun).
 
1 - 10 of 10 Posts
Top