Mercury Cougar Owners banner

1 - 20 of 27 Posts

·
Registered
Joined
·
866 Posts
Discussion Starter #1
Hey guys, I installed my Transgo shift kit today, well, had a friend install it, while I was at work :D And it really does shift alot nicer (No second gear chirp for me anymore =( ) But one thing I noticed is, it doesn't seem to go back into first gear when I am at a stop sign anymore, instead it will stay in the gear it was in, and when I hit the gas it drops into first and really lights the tires up, and I mean really. Now, I don't have the drop down linkage on my carb, but I do have the vacuum, and it worked fine before.

Does anyone know what could be causing that? I know a few of you have this kit *Cough cough Logan cough cough*. Anyone seen anything like this?
 

·
Registered
Joined
·
866 Posts
Discussion Starter #2
And on top of that, I had a root canal done a little over a week ago, and it started to hurt really bad the next day. Well the dentist kept telling me it was normal, so I lived with it, went on my vacation and came back. Once I got back it started to hurt like hell, so I come to find out I have had an infection in my tooth for over a week and have done nothing about it! So because it has been growing for that long, it has spread to my entire "drivers" side of my jaw (Ugh, see, I'm starting to think of myself as a car now!).

Talk about the pain!! My mouth is swolen and feels like it is in a vice! Not even the mighty Vicodin seems to be helping! I hate my dentist!!!!

lol sorry, I'm venting, because I can't actually talk right now :cry:

Chris
 

·
Registered
Joined
·
866 Posts
Discussion Starter #3
Oh, and it also has a delay from N to D. When I put it in D it takes a few seonds to go into D. But if I go from N to 2 or N to 1 it goes almost instantly.

Thanks

Chris
 

·
Premium Member
Joined
·
3,404 Posts
Sorry to hear about the mouth.
Shift kits dont work from 2-1 like they should. When you down shift to 1st, kick the rpm's up abit, it should throw you forward.lol. Is your fluid level topped up properly, and the fmx has an adjustable vac. mod you might try adjusting it in or out for the best shifts. My C4 doesnt downshift from 2-1st over 30mph, and when I hit 30, I stomp on it, and it just learches big time,:D

Good luck,

Rick
 

·
Registered
Joined
·
866 Posts
Discussion Starter #6
Also, When I mentioned about not downshifting, I meant, if I come to a stop at a light, it wont go back into 1st. Until I hit the gas.
 

·
Premium Member
Joined
·
2,048 Posts
Mine is the manual valve body kit. I have to shift everything myself. Just the way I like it.

But, you need to hook up the kick down rod...
 

·
Registered
Joined
·
1,112 Posts
I also have the 37-1 kit and am not having the problems you describe. You really need to hook-up the kick down and see how it drives. When I come to a complete stop, my FMX does shift into 1st. Also, I constantly get chirp when shifting from 1st to 2nd and under WOT many times chirp the 2-3 shift.

The current 37-1 kit is not programmable for lighter or harder shifts.
 

·
Registered
Joined
·
866 Posts
Discussion Starter #9
Transgo thinks the govener valve is sticking, or something is wrong in the valve body... but I double checked everything though! I thinking about that vacuum module, when I tried to shove a wrench inbetween it, it moved out a little, the way it would make it shift softer and sooner, and it is certainly doing both!
 

·
Registered
Joined
·
600 Posts
Well i can say i am gld that you posted this before i went and dropped the ching on a kit, at least now i know what to look for!

By the way whats the kit cost?

Thanks
 

·
Registered
Joined
·
866 Posts
Discussion Starter #11
45 bucks, but I think I figured it out. I messed up my vacuum modulator, and I am pretty sure thats why the shifts aren't that firm, so in about an hour when the new one goes on I will know. And as for the lack of downshifting, I think it is because I reused the same oil (only had about 100 miles on it!!) and it might have been a little dirty, so after I drive it a while the govenor valve should open up. So everything "should" be okay.
 

·
Registered
Joined
·
600 Posts
45 wow not bad at all!
Oh Chris how is the tooth doing? I have been plagued with dental issues for like 4 years now and know your pain man!
 

·
Registered
Joined
·
866 Posts
Discussion Starter #13
Really bad! I just went today, and he drilled a hole in the top of the root canal tooth and said that should releave the pressure. I can't even go to work today it hurts so bad. My mouth is all swollen too :cry:
 

·
Registered
Joined
·
600 Posts
ewwwwww

Yup been there , altho my teeth always decide to go bad on a sat night, so there are no dentist available!

Oh and let me know if the new valve works out on the trans.
 

·
Registered
Joined
·
866 Posts
Discussion Starter #15
Put the new modulator on, did nothing, drove it for about twenty miles, got worse. Drove it to Burbank Transmission, he said it was screwed up bigtime. Drove it home, ripped into the tranny again and pulled out the valve body.. It seems my friend (backyard mechanic) didn't clean it up very well (Actually, he didn't clean it at all) when he did it. I looked it over before it went in, but didn't really open it up. So tonight when I opened it I noticed almost all of the valves were sticky and some wouldn't come out until I pouned the valve body on the table!

So, I cleaned everything up (Gotta love brake clean!) , and redid it (Shoulda done it myself in the first place, darn work!), and all the valves feel nice and smooth. So tomorrow I'm gonna go up there (I left my car on stands in his backyard) and put her in! I will tell you all how it goes.

Chris
 

·
Premium Member
Joined
·
3,404 Posts
Good luck Chris, yeah I guess its better off to wait and do it yourself. I will from now on:D Hope all is good when you button it back up.

Rick
 

·
Registered
Joined
·
246 Posts
Where'd you get the kit?

I've been looking to help out my FMX.
 

·
Registered
Joined
·
866 Posts
Discussion Starter #18
I got it from TXExchange, if you look under the post FMX Shifting, someone placed the link on there. I cleaned the valve body, and it does shift alot firmer, but it still doesn't drop into 1st when I am at a stop in D, unless it is cold. And what I also noticed is, at a stop, when I put it in 1st, it goes to first, 2nd, it goes to second (it doesn't start out in first like it should), and when I put it in D, it starts out in 3rd, but when I give it gas it goes back to first.

Logan, you mentioned you had a manual shift kit for your FMX from Transgo, where you have to shift it all the time, yet Transgo said they didn't make one like that. Do you have a part number by chance?

Thanks

Chris
 

·
Registered
Joined
·
3,141 Posts
"...2nd, it goes to second (it doesn't start out in first like it should)... "

cmpcpro: An FMX is in 2nd as long as the shifter is in 2. Same for First gear when 1 is selected. D will shift all the way through 1-2-3 and back down.
It sounds as if you have a pressure problem with the lack of a downshift to first. Are you using Type F fluid?
The kickdown linkage will not keep it from shifting into first, if it is in the "on" position it will create higher RPM upshifts and lower RPM downshifts. If it is in the "off", or normal position, it will shift up sooner regardless of load and will only downshift at slow speed.
I would tear into that valve body and check every spring (they should be color coded) and check ball.
 

·
Premium Member
Joined
·
2,048 Posts
Chris, sorry I don't have the box anymore, and can't remember off the top of my head. I don't see it on their website, I wonder if they discontinued it? I bought the kit over 2 years ago...
 
1 - 20 of 27 Posts
Top