Mercury Cougar Owners banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3,141 Posts
Discussion Starter #1
I bought a set of under ride traction bars for my 69 about a year ago and am finally getting around to putting them on as I replace the rear springs and guess what - they don't fit! :(
The hole spacing side to side is 3". My plates are 4". :rolleyes:
So what is wrong here? I know that the springs are different lengths than a Mustang, but are the plates wider as well? Maybe due to the rubber pads? Front to back is fine, but not side to side.
The application says Mustang/Cougar....:confused:
And more good news, the staggered shock plates won't work either because they line up with the trac bars!:angryfi:
Can someone please tell me what is wrong here? I need to know the correct side to side spacing of the U-bolts for a 69.
 

·
Moderator
Joined
·
11,000 Posts
Bob,
You have to get lower shock plates and U - bolts from a 67 - 70 Mustang and delete the rubber spring isolator clamp assemblies on the Cougar springs. You also need the lower spring / shock plates from a Mustang.
 

·
Registered
Joined
·
3,141 Posts
Discussion Starter #3
Thanks, Royce! I thought that I was losing my mind for a while there. Now that I know where the "problem" lies I can fix it. Maybe I will make my own rear plates for the Trac bars.
 

·
Moderator
Joined
·
11,000 Posts
Be sure to reinstall the cast iron wedges below each spring perch, they have to be there or you break u - joints because the pinion angle will be off.
 

·
Registered
Joined
·
3,141 Posts
Discussion Starter #5
Will do. Thanks again.
 
1 - 5 of 5 Posts
Top