Mercury Cougar Owners banner

1 - 10 of 10 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1 (Edited)
those darn turn signals

I know there are a million questions and answer threads out there but here it goes, I have running light and brake light but no turn signals I have jumped the turn signal switch and the s.box clicks but still no signals. I am getting juice from the switch to the set up in the truck when I jump the switch , what am I missing here or perhaps not doing right? hazards do not work either.
67 cougar thanks for any help
 

·
Registered
Joined
·
89 Posts
if its a 67/68, sounds like either the fuse to the turnsignal switch or the turnsignal switch itself. I'll bet the horn doesnt work either since the wiring for the horn is in the switch as well.
 

·
Registered
Joined
·
3,371 Posts
Make sure there's a ground terminal attached to the bracket above the fuel filler tube in the trunk. this comes out of the taillight wiring harness.... 67/68 cat...


Don
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
thanks for the info

the horn works along with headlights and running lights, no turn signals or hazards.Has anyone ran a separate aftermaket turn signal switch? I am thinking about doing this in order to pass state inspection. I have looked at the wiring diagram in my mustang/ cougar manual but can't make heads or tails of it.

Thanks to all for the help
 

·
Registered
Joined
·
89 Posts
What year is your car?
NO, I dont believe you can run a separate turnsignal switch. The early cougars turnsignal switch has a wire for each lamp i believe.
My switch had 10 or 12 wires. They are the same for T BIRD as well.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #9
carbuffxr7

Just got them, thanks I owe you big time. can't wait till the rain stops so I can get to work on the lights. Your info really puts the manual to shame.
thanks a million
Tony
 
1 - 10 of 10 Posts
Top