Mercury Cougar Owners banner

1 - 6 of 6 Posts

·
Registered
Joined
·
305 Posts
Discussion Starter #1
Just curious if anybody has encountered a similar problem. I'm trying to put timing gears in my 351W, and the timing chain cover wont clear do to a peice in the middle near the crank seal that extrudes quite a bit. When I try putting it on, that peice hits the middle section of the timing gears. I was thinking about milling it off and see if that works, but still unsure if i will have enough clearance. Has anybody else run into this problem? If so, what was your solution. Or is there an aftermarket cover out there that can solve the problem. Thanks for the help.

-Josh
 

·
Registered
Joined
·
588 Posts
I've replaced timing chaings on several windsor motors and I've never ran into that before. If the timing chain is something besides a stock replacement set, it may be the problem. I've heard that with gear drives that the tab you are talking about has to go.
 

·
Registered
Joined
·
3,141 Posts
Minimum Wage 69 said:
I'm trying to put timing gears in my 351W, and the timing chain cover wont clear
Bruce is correct. You have to grind off that tab in order to run gears. That tab goes between the sides of the chain, but with a gear set there is no between anymore.
 

·
Registered
Joined
·
253 Posts
Josh, It sounds like you should give the gear drive manufacturer or the vendor a call. There must be something they didn't tell you or give you. All I know about the gear packing is that there is minor machining work that needs to be done, problem is I have never been told what it was.

Good Luck
 
1 - 6 of 6 Posts
Top