Mercury Cougar Owners banner
1 - 5 of 5 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Hey Guys,

just got the coug out of the shop, got a guy to take out the old 3spd, put in the new clutch/t5 for about 300 which seems pretty solid to me. Drives great and back to prowling the USC campus! I do realize after looking at this picture that I need to re-adjust the console. The speedometer is now off, and the guy couldn't figure out the parking brake (that worked previously) so if y'all have insight into that...

 

·
Registered
Joined
·
7,555 Posts
Congrats on getting it back! 300 is waaaaaay better than my bill was!
 

·
Registered
Joined
·
1,076 Posts
To get the correct speedo gear, you'll need to know the rear gear ratio and the tire size. Use a GPS to determine how much the speedo is off, then contact Bruce at Modern Driveline (he's a member here). He'll be able to help you. He provided me with a gear that is just one MPH off. And there's always the possibility that the speedo isn't 100% calibrated.

If your e-brake worked before, there's no reason why it shouldn't be working now, unless the brake cables interfere with the...dare I say it...tranny. And if so, they can be adjusted.
 

·
Registered
Joined
·
2,036 Posts
Which did you do, the Cougar bellhousing, clutch, and linkage, or did you go with the t-5 bellhousing, cable, and clutch?
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #5 ·
I used all the T-5 equipment. Driveshaft did not have to be altered, and strangely enough he said the old tranny mount was better than the brand new one from NPD (which he gave me to return).

And thanks conv cat for the speedo advice! I'm still working on the exact mph it's off.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top