Mercury Cougar Owners banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi everyone,
I have a strange sound coming from my 02 cougar when i rev it up past 4000rpms. sounds like WOO-B-B-B-B-B-B-B-B. THATS the best i can discribe it as. I changed the mass air and thought it was gone but lost my clutch so I parked it for about a year. now I am trying to get it back on the road and found out I didn't lose my clutch after all...i think. The sound seems to be coming from the trans area. I did a motor change a while back but never replaced the clutch. I did have to change the slave for the clutch right after the motor was back in the car and I was going to do my first test drive..needless to say that ride didn't happen. so out with the motor again and in with the new slave for clutch...so dumb!!!
does anyone know what that sound could be? I will try to post a video of the sound after this post.
 

·
Premium Member
Joined
·
13,577 Posts
Sounds like some air injection valve or something, but I don't know anything about the newer Cougars. Here is the place you want to go to talk with people who do:

http://www.newcougar.org/

Good luck and hope you get to the bottom of your issue.

Regards,

Bob
 

·
Registered
Joined
·
48 Posts
Well I can't get the video to play on my mobile telephone device I've done a little work to the newer cougars if you can get me the video I might could help or I could completely waste your time it could go either way
 

·
Registered
Joined
·
11,950 Posts
Maybe it's purring...... ;>) bada-bump, I'll be here all week.....
 

·
Registered
Joined
·
8,194 Posts
Changed the engine without changing the clutch? That's a no-brainer in the "I might as well do it while I can" category.
 
1 - 9 of 9 Posts
Top