Mercury Cougar Owners banner

1 - 8 of 8 Posts

·
Registered
Joined
·
308 Posts
Discussion Starter #1
Tuned the cat (73 xr7 351c, stock 2bbl carb) 2 weeks ago.... smmoooth. Yesterday wife noticed it was wanting to stall when slowing. I drove it abound the block, sure enough it would stall if lots of gas was not given. I checked the Fuel Filter- OK I'm thinking:
Pertronix possibly shorted so its ok at throttle;but wont maintain idle? OR Power Valve/accelerator pum need replacing- any thoughts here? OR coil?-would this allow it to run at higher speeds but stall at idle? Thats it for a jump off point- I'll add that the timing was just set at 6 BTDC; but now shows at 21BTDC whats with that? HELP, HELP.

Thanks, Ed
 

·
Registered
Joined
·
121 Posts
Could be a bad distributor also.
 

·
Registered
Joined
·
3,141 Posts
Did you time the motor with the vac advance disconnected? Both times?
 

·
Moderator
Joined
·
11,000 Posts
Sounds like the timing chain jumped a few links, when was the last time you changed it?
 

·
Registered
Joined
·
3,141 Posts
That was my thought. Wasn't sure if he timed it the same way both times or not.
 

·
Registered
Joined
·
308 Posts
Discussion Starter #8
So far...

I looked over the vacuum lines and found a big leak where a hose was torn at the carb. Cleaned the carb, changed out some lines(vac.) Ran well on test last night- thought the prob was fixed... This AM the wife drove it breakfast with no probs, then on the way home, same deal needs plenty of gas or it will start to stall and eventually die- any last thoughts before I break the seal on the CARB REBUILD kit?
 
1 - 8 of 8 Posts
Top