Mercury Cougar Owners banner

1 - 7 of 7 Posts

·
Registered
Joined
·
380 Posts
Discussion Starter #1
I am still trying to get my p/s pump back from Randy. my last communication from him was on November 30th. I understand he is not big on answering the phone or returning emails but this is ridiculous.

I posted several months ago about this and shortly after that got my one reply. It may have been just a coincidence, but I figured nothing else has worked so I would try this again. If any of you know Randy or live close to his shop in San Antonio, could you help a brother out? 1970 Cougar p/s pump. Just need to know if he is gonna' rebuild and return the pump, if it got destroyed, if i need to purchase a new one, etc. thank you-
 

·
Registered
Joined
·
980 Posts
Hate to say it...but, sounds like you would be money and time ahead to go and get the new one...situations like this always pi$$ me off. Without hearing the "other" side of the story, you have to take a stand a decide how bad you want to drive it, can you wait any longer ??? (he may have a good reason)...if you get it tomorrow, will you drive it that day or wait till the weather is more summer like??? If you CAN wait, give the guy another chance... just sayin....
 

·
Registered
Joined
·
41 Posts
Can't help you with your problem, sorry, but I did just order this $43 remanufactured pump for my '70 Cougar from Summit Racing...
http://www.summitracing.com/parts/AAZ-20-6142/
Haven't received or installed it yet, so I can't say how good it is (or isn't) but the price seemed reasonable, and it includes the reservoir so it's "plug and play".
I also have a seal kit for my current leaky PS pump, but given how badly I did on my '71 Javelin PS pump rebuild I figured I'd go with the reman first, LOL!
Best of luck!
Jeff
 

·
Registered
Joined
·
8,194 Posts
I had problems with a "remanufactured" pump from a local parts store, so I obtained an original pump that was originally in a 70 Cougar. Never a problem, no leak or any other issue.
 

·
Registered
Joined
·
1,044 Posts
i agree with yeloxr7---get an orig pump and at least change the large can o'ring---ours started leaking so we got a rebuilt---involves un charging the a/c and having the pully r&r to get the bracket---the new pump failed on the way to the auto parts to get my core---thank god i hadn't charged the a/c
 

·
Registered
Joined
·
118 Posts
He's got mine too......last I heard from him was Dec 29th.....I do wonder if he's OK or just not answering folks now.....left several messages over the last 3 weeks and nothing?
 

·
Supporting Vendor
Joined
·
1,014 Posts
I'm having the same problem with Randy. Sent two control valves and two cylinders back in September. After numerous messages and emails I finally heard back from him in mid-December with an apology for taking so long and an assurance they would be done in a couple weeks. Still have not seen my parts. No way to run a business!
 
1 - 7 of 7 Posts
Top