Mercury Cougar Owners banner

1 - 4 of 4 Posts

·
Registered
Joined
·
866 Posts
Discussion Starter #1
Well, I've had it. I've spent too much money trying to fix this hesitation. And it almost seems like the engine is missing at idle. So tomorrow, I am going to call the local automotive shop and ask them to drop it off and let them take a look at it on the scope. Maybe that will tell me whats going on.

I've never seen a car, that drives good, and then 20 minutes later drives like it's bringing grandma to church.

Is there anything else I should have them check?

Thanks

Chris
 

·
Contributing Member
Joined
·
5,865 Posts
Check for vacuum leaks on all the hoses. Sometimes they harden and don't play up until the engine is worm or starts rocking after acceleration. Also check power booster vacuum and oneway vacuum valve to see if they have leaks.

Leaking or cracked exhaust manifold will also cause slight miss at idle and create poor performance when hot

Other than that - the usual cuprits - points/ coil/ leads
 

·
Registered
Joined
·
2,145 Posts
Check the rotor shaft for play, sticky advance plate.
Fuel, Spark, Vacuume.
What have you chaecked so far?
 

·
Registered
Joined
·
2,145 Posts
Electric fuel pump

Are you running an Electric fuel pump on this car?
I had one on my 67 stang and it was not a good thinng. It would start to cavitate after about 30 min. and that would put air into the gas flow and the would cause the car to run like crap and then die like it was out of gas. So I spent a little more and baught a high quality mechanical pump from Ford Mans Mustang and it was fixed. Buy Cheap...Buy Twice.
 
1 - 4 of 4 Posts
Top