Mercury Cougar Owners banner

1 - 8 of 8 Posts

·
Registered
Joined
·
667 Posts
Discussion Starter #1
Over the winter had some bad valves so all new valves, springs some mild port work new thumper cam took me for ever playing with the dis and wires to got it to hit. It will run but pops from the carb here is what im thinking

1-the chevy design dis
2-the cam is to big needs 9.1 i have 78 motor .40 with 68 heads 53.5cc I think Im good on the compression.
3-Human error
4-wiped the cam out adjusting the rockers

I never In my life had this much trouble getting a car to fire and run i was looking at this I have a new box for it.
http://www.summitracing.com/parts/MSD-8582/RequiredParts/?prefilter=1
 

·
Premium Member
Joined
·
13,577 Posts
Couple thoughts.

1. Thump'r cams are gimmicky at best (but should not cause the problems you seem to be having).
2. Do you have a 302 or a 351? Have you considered the 302 firing order vs. 351 firing order and know for sure which the cam is ground to? Backfiring to me sounds like you still have wires crossed.
3. GM HEI type dist should not be an issue.
 

·
Registered
Joined
·
980 Posts
What Bob said, wrong firing order...try the other one. Did it to myself one time, even invented new cuss words over it. My wife came out to the garage in time to hear me cussing it out, she asked me "what's wrong"? and I told her that "the engine was screwing me"... without missing a beat, she said "Is it screwing you, or are you screwing yourself"? Turned out she was right, I was indeed screwing myself..using the wrong firing order.
 

·
Registered
Joined
·
11,950 Posts
Agree - typically modded cams on 5.0's are set to 351W firing order since it's easier on the crank....I'm sure you have beat the off by a tooth or 180 degree off horse to death, but it never hurts to have a sanity check....make sure it's the right stroke at TDC...yada, yada
 

·
Registered
Joined
·
667 Posts
Discussion Starter #5
Wish I would of read this when I got up another day wasted cant wait to try it tomorrow I have been using the 302 firing order. Here is the only thing I could find in print about using 351w firing order Think They would give you that info on the cam card

http://www.who-sells-it.com/cy/northern-auto-parts-648/issue-96-22762/page-17-fullsize.html

Have to read down a bit but its saying what you guys are telling me use 1-3-7-2-6-5-4-8
I will update Thanks guys
 

·
Registered
Joined
·
667 Posts
Discussion Starter #6
Umm that was it but still have some problems runs about a min then cuts off should I use 351w rocker adjustment also?
 

·
Registered
Joined
·
11,950 Posts
Yep - follow that order. You mean just dies - like no spark... or sputters out like lack of breathing...? What about with advance plugged/locked (vac or mech?)
 

·
Registered
Joined
·
667 Posts
Discussion Starter #8
Well I went and got a new msd dis and coil already had a new box. Used the 351w specs fired right up If it runs half as good as it sounds should be alot of fun..Still got some bugs to work out with water pump and fan relay few other things but Im back on track Thanks again Ron
 
1 - 8 of 8 Posts
Top