Mercury Cougar Owners banner

1 - 7 of 7 Posts

·
Registered
Joined
·
166 Posts
Discussion Starter #1
Can anyone reccomend a good motor and tranny mounts for a 69 with a 302. The rubber on the driver side mount I got form Mstng unlmtd ripped on me after only 2 months, and I certaintly dont want to use them again. Thanks
 

·
Registered
Joined
·
206 Posts
Try this site. It looks like they have a pretty trick set up for the engine mounts.

http://www.totalcontrolproducts.com/motormounts.html

I don't know about tranny mounts. I've never heard of one going bad outside of stock applications and street performance.

Good luck!
 

·
Registered
Joined
·
2,145 Posts
I had the same deal. The driver side engine mount would rip, I finally used a chain and turn-buckle.
there is a mount that had a stud thru it to hold them together also. I was running a 289 hipo w/ a top loader, a hard launch wouild rip that puppy until I chained it down.
 

·
Contributing Sr Motorhead
Joined
·
5,470 Posts
Torn/ripped motor mounts

After several lawsuits from incidents caused by ripped motor mounts (even waaaaay back then), Ford finally got a better idea and started making 'captive' mounts. That is, the rubber insulator is totally surrounded by metal in some manner or another. That way, even if the rubber should rip, the engine was still held in place. I think this is one of the changes that came about in about 1971-72.

You can retrofit the later mounts to an earlier car with no problems IIRC. Both of my Cats are 73s with Cleveland CJs and already have the 'good' mounts. Mine have stood the test of 400+ HP in AlphaCat (12.80 quarter-mile times) and no problems.

To use the later-style mounts, you'll need both halves of the mount -- the part that bolts to the engine and the part that bolts to the frame. You might have to drill a couple of new holes though.

Good luck!
 

·
Registered
Joined
·
2,867 Posts
Any updates??? (Poly engine mounts?)

I know this thread is old, but I'm fixin' ta put new '68 mounts in my '67 (got the '68 SB frame brackets, thankyouverymuch guys!) and was thinkin' I might wanna put Poly mounts in instead of rubber...any thoughts?

I only have a medium-built 302, and it really only torques off the stop signs (hey, I can't HELP it...that's why I got the locker rear end!)
 
1 - 7 of 7 Posts
Top