Mercury Cougar Owners banner

1 - 2 of 2 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
bought a brand new carb. hooked it up and now it spews gas out of the top of the carb.
(I guessed the float was stuck so I took it back)

I got the OLD carb rebuilt/cleaned and now it does the same thing?
(spews gas out the top) like streams of gas...

(THE FIRST TIME I DECIDED TO MESS WITH THE CARB IS BECAUSE IS HAD BEEN ON THE CAR FOR 40+ YEARS) and the car would idle and die. figured it was just dirty and time for a new one.

what could be happening.

(some back story)

car was sitting for about 10 years at my dads house.
*motor wouldn't turn over turns out it something was just lodged in between the starter teeth.)

anyways brought it back
(got fuel tank cleaned recoated. fuel lines cleaned/fuel filter changed/oil filter changed
fuel pump still works (6.5 - 7 lbs pressures) radiator rebuilt.) all new brakes tires

was running great for about 3 weeks (besides trouble starting **which I contributed to the carb being dirty/gunky)

then all of a sudden car stalled while on the road, pulled off to the side and cranked it and It started right up.

then I left it in the driveway ilding for about 3 minutes and then it died. havnt gotten it to idle since then. (two carbs later)

turns over just wont start and while im trying to start it (gas spews out like a geyser inch of gas streams threw the two top rods or vents whatever they are
 

·
Registered
Joined
·
2,153 Posts
sounds like your float is sticking or needs to be adjusted... I would get in touch with your re-builder and see what he has to say about it... make sure you mention your 6'5 to 7 psi fuel pressure.

 
1 - 2 of 2 Posts
Top