Mercury Cougar Owners banner
1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hello all,

I am having trouble determining what the cause of my inst. panel lights not working is. Before you suggest, I already checked the fuse. I have traced the wiring as best as I could and it seems as if everything is connected. The gauges work fine, but when the headlights are on, I get nothing inside. Since I recently rebuilt the engine, I liek to see my temp and oil gauges to enjoy the fact that they are running as expected.

If anyonce can offer advice, that would be great. I know this is vague, but if you have an idea of where to start I will start there.

Thanks.
 

·
Registered
Joined
·
197 Posts
dash lights out?

What year is your cougar?

Do the lights work for the radio? It could be the
potentiometer at the headlight switch. Check fuse panel again
and owners manual fuse information.
 

·
Contributing Member
Joined
·
6,137 Posts
Could be a simple thing, but is the dimmer turned down too far... I speak from experience when I first got my car...

Mark
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Thanks for the help. It is a 68 xr7, sorry I did not mention that.

The radio is out completely (along with the console etc). Could this be the problem. I am redoing the interior as we speak. I suspect the head light switch as well, so that will be replaced (it should be cheap).

I check the dimmer a while ago, that was not it, but I sure to wish that was. Also the fuses have been triple checked and there was a blown fuse a while back, so it was replaced. Now the fuse it fine.

I will look into it and give an update after the weekend.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top