Mercury Cougar Owners banner

1 - 10 of 10 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
My '68s driver side fender doesn't have holes in it where the Mercury emblem was. In fact, it doesn't even look like it ever had the emblem there, i.e. no marks of any kind in the metal. Did some '68s not come with the emblem?

Also, and more importantly, I bought an emblem and I'm wondering if anyone has any lining up/measuring suggestions for me?

Thanks a million.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #3
The part of the fender on the front of the car.
 

·
Premium Member
Joined
·
328 Posts
Should have been the Mercury emblem on the fender extension. You might check to see if the holes were filled at some time.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #6
Yeah but it looks clean and flat; I can't tell where exactly the emblem was originally.
 

·
Premium Member
Joined
·
4,105 Posts
Get a mirror and look at the underside. I bet the holes were filled.
 

·
Registered
Joined
·
175 Posts
Is this the one you are talking about? I don't have measurements but you should be able to reach the backside and feel the holes or bondo.



 

·
Registered
Joined
·
28 Posts
Discussion Starter #9
I actually just decided to take the fender extension off and it answered all my questions.

Thanks to everyone though.
 

·
Registered
Joined
·
2,991 Posts
I actually just decided to take the fender extension off and it answered all my questions.

Thanks to everyone though.
So, what did you find out? Enquiring minds want to know.:)
 
1 - 10 of 10 Posts
Top