Mercury Cougar Owners banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi,
I'm a newbie cougar owner with a 71 XR7 Convertible. The problem I'm having is the temp gauge reads hot while i'm driving at highway speeds when I slow down to 30-40mph the temp drops down to normal. I have removed the thermostat to see if thatwould help and it doesn't, I tried installing an electric push cooling fan and it still runs hot, I even tried some stuff called 40 below that claims to reduce temp up to 20 degrees and it still didn't help, i've changed the gauge in case that was the problem and it still shows hot. The radiator is fine with no blockages and the water moves well in it. the water pump seems to be ok also.

Does anyone have any ideas or suggestions? i find it unusual that it happens when i go over 45mph but under it runs normal.

thanks in advance for your help

Lyle
 

·
Registered
Joined
·
3,201 Posts

·
Registered
Joined
·
1,832 Posts
I have a few questions. How did you come to the conclusion that the radiator is fine? Did you have it out and checked? How old is it? Is it the correct radiator for the car? 90% of time the troubles you describe are caused by lack of flow in the radiator or a radiator too small a capacity for the car.

You dont mention losing any coolant so for now so a cracked head, block or blown head gasket probably dosent come into play. mm
 

·
Registered
Joined
·
3,201 Posts
Yeeouch, mm, don't be so depressing, my list of things to check is getting longer and longer.:D
 
1 - 5 of 5 Posts
Top