Mercury Cougar Owners banner

1 - 4 of 4 Posts

·
Registered
Joined
·
374 Posts
Discussion Starter #1
Does anybody know the resistance values for the 2 resistors on the 3 Speed Heater Resistor Assembly for a 67 Cougar? Or is there anybody that has it out and could measure? :confused:

I know I can (and probably should) buy the whole assembly, but for where I am at it will be 4-6wks before I have it and appr $35, I just want to take a stab at fixing it earlier & cheaper (without setting fire to my car).

tnx
 

·
Registered
Joined
·
5,633 Posts
Have you pulled the old one yet? They seem to fail most often at the end of the resistor wire. In many cases it is vibration that fatigues the wire and you can just reattach the broken end. These are high power rated resistors so don't try to throw just any thing in there. Your best shot at a work around would be to use a similar part off a different car. I would look at other European Ford products (old Capri maybe?) for a similar part.
 

·
Registered
Joined
·
374 Posts
Discussion Starter #3
No I havent yet. Have planned to do this tomorrow with some other small stuff and this thread was in preparation of that. Tnx. I had checked out wirewound resistors 4W sofar. But a simple mechanical fix of what is there is most preferable ;-)) so your info is encouraging. Will let you know where it ended.
 

·
Registered
Joined
·
374 Posts
Discussion Starter #4
You were right Bill. One of the coils had simply broken (and been soldered together) once. I didnt think soldering was a good technique here since these things can get hot so I clamped them together. Works as/with a breeze again. Meantime found one of the hoses to the windshield vents had come off so my defrosting performance has improved exponentially. Tnx again!
 
1 - 4 of 4 Posts
Top