Mercury Cougar Owners banner
1 - 9 of 9 Posts

·
Registered
Joined
·
131 Posts
Discussion Starter · #1 ·
Old problem, finally getting to. When I stop the car and turn it off in the garage, I can hear the gas sloshing around AND a "thunk, thunk" thunk" as the waves slowly die down. Also, when I fill it, the gauge only goes to 3/4 full. Something lose in there. Or corroded so ordered a new sending unit from West Coast Cougar just to have it if I'm switching it out. Not sure if that's what's causing the gauge problem.

Have heard two trains of thought: 1) you don't have to drop the tank to get to the unit, you go thru the trunk. and 2) you DO have to drop the tank to get at it.

Question: Does anyone have a definitive answer? and also, is this probably the cause of the gauge not going to F.

thanks,

Chris
 

·
Registered
Joined
·
442 Posts
you dont have to remove the gas tank, it does have to be drained. Get it out from under teh car.
 

·
Registered
Joined
·
274 Posts
The fuel gauge in both of my 69's act the same (reading too low) and I wasn't able to resolve it. I think we have to live with it!

JAMES
 

·
Registered
Joined
·
383 Posts
Same here, replaced the unit on my 69, still reads only 3/4 full when the tank is filled to the brim. All conctions are good, good ground etc, ...
I think the sending units now (repro) are not exacly a match for the old gauges.
 

·
Registered
Joined
·
66 Posts
I have an original sending unit in one of my 69's and it still reads 3/4 when full.

JAMES

Even from back in the day, they read 3/4 when full, then slowly moved a bit towards full and then decended as fuel was consumed. It wasn't accurate then and surely won't be now. Know your car and how to most accurately estimate until you're used to it. Trust me, don't chase this issue.

rcode
 

·
Registered
Joined
·
131 Posts
Discussion Starter · #8 ·
Old problem, finally getting to. When I stop the car and turn it off in the garage, I can hear the gas sloshing around AND a "thunk, thunk" thunk" as the waves slowly die down. Also, when I fill it, the gauge only goes to 3/4 full. Something lose in there. Or corroded so ordered a new sending unit from West Coast Cougar just to have it if I'm switching it out. Not sure if that's what's causing the gauge problem.

Have heard two trains of thought: 1) you don't have to drop the tank to get to the unit, you go thru the trunk. and 2) you DO have to drop the tank to get at it.

Question: Does anyone have a definitive answer? and also, is this probably the cause of the gauge not going to F.

thanks,

Chris
UPDATE: New sending unit solved the problem. Fill it and goes all the way to FULL.
 

·
Registered
Joined
·
9 Posts
UPDATE: New sending unit solved the problem. Fill it and goes all the way to FULL.
It seems we need a new sending unit as well. The fuel reading has been acting lately and making some noise. A new set of tires from 4 Wheelonline will be installed soon and we'll work on the sending unit next.
 
1 - 9 of 9 Posts
Top