Mercury Cougar Owners banner

1 - 3 of 3 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi Guys I have a 1970 xr7 convert with an fmx.....the transmission works and shifts fine...
although unlike my previous 1969 fmx it doesn't click when shifted from 1-2 or 2-3
I'm not sure what adjustments need to be done or if this is just a 70 issue ....btw the shifter appears to be correctly aligned ...I'd appreciate your ideas
regards
 

·
Premium Member
Joined
·
4,097 Posts
What does "doesn't click when shifted from 1-2 or 2-3 "? Are you referring to the shifter not making a click? Or the transmission. It the shifter try removing the bezel and handle cleaning and lubricating the release cable and detente. Also look it over carefully for worn out parts.
If the problem is in the transmission I do not have any advice.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
What does "doesn't click when shifted from 1-2 or 2-3 "? Are you referring to the shifter not making a click? Or the transmission. It the shifter try removing the bezel and handle cleaning and lubricating the release cable and detente. Also look it over carefully for worn out parts.
If the problem is in the transmission I do not have any advice.
Thanks BC I have looked , it appears that it is all lubricated and yes the clicking is in regards to the detents, it doesn't lock out from park to reverse which a 70 is suppose to,so i'll look at the column alignment....weird that it seems to be working correctly ...starts in neutral etc....if anyone else recognizes this issues please chime in .....hope you all enjoyed the 4th
 
1 - 3 of 3 Posts
Top