Mercury Cougar Owners banner

1 - 4 of 4 Posts

·
Registered
Joined
·
505 Posts
Discussion Starter #1 (Edited)
OK ... here's a tough one ...

Going to install the rear, splash shields in the front fender wells. Fenders are off, great time to install, but hitting a fastner issue. There are three mounting points top, side & bottom. From my box of parts that I acquired, I have 1 and a half sets of splash shields. There is only one U-Clip found on the top of the splash shield. It accepts a hex head screw that comes down from in front of the cowl ... through the rear inner fender aprons ... and then into the splash shield. Cool no problem.

The two clips that I have work perfectly with the replacement bolts I have from WCCC. The U-clips (I've also seen these refered to as spring clips) have a "14" stamped on them. Since I don't have any for the bottom or side ... I bought a box of 1/4" U-Clips from Fastenal. Close but these will need to be modified to work. The bolts are still too big.

What size is the original U-Clip? Is it 5/16"??? I am going to try and drill a couple out this weekend and attempt to make them work ... just curious if anyone knows the answer. Does anyone know if the same clips are used on the side and bottom. This is another one of those jigsaw puzzle moments when trying to reassemble.
 

·
Premium Member
Joined
·
13,577 Posts
Eric,

The rear fender shields only have one J-clip each, the hole at the top which attaches to the top of the rear fender apron. The other two holes are (working downward) attached with a screw to the cowl side vent pinch weld and with a screw to the L-brackets that are also used to attach the front of the lower fenders to the rockers.
 

·
Premium Member
Joined
·
13,577 Posts
Glad to help Eric.
 
1 - 4 of 4 Posts
Top