Mercury Cougar Owners banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5,299 Posts
Discussion Starter #1
i was driving out to cause trouble out in LA tonight when the Alternator light on my car came on. uh oh..... was able to drive it back home the several miles in traffic and shut it down to put it in the garage ( the garage keys are on the same chain. ) went to fire the car up and just heard a click. this has happened before ( sans Alt light going on ) so i turned the pos battery cable and tried to start it again thinking it would fix ilike before. no difference.l turned it again but left the key on. then i jumped the starter solenoid terminals. it fired up fine but the alternator light was still on. im not happy about this so umm any suggestions?? could it be the battery cable loose or maybe dirty? dammit. i just buffed it out and got it ready to take to the SoCal meeting tomorrow but now if its doesnt start im gonna have to do parts runs all day. figures it happens when my day off is tomorrow. grrr.. only get one Saturday a month off.
 

·
Registered
Joined
·
5,299 Posts
Discussion Starter #3
long as the car starts ill be there. i have AAA i can get towed back lol
 

·
Registered
Joined
·
300 Posts
hehe, ok...

I'm taking the mustang... have to go drop off the old stereo/amp that was in it before. And the guy I got it from wants to see how it's progressed...

go figure..

SEE ya tomorrow
 

·
Registered
Joined
·
5,299 Posts
Discussion Starter #5
took the car to Sears today. they tested the car and found that the alternator wasnt putting out any amps. so i got a new one and bought a new regulator for the hell of it. tomorrow ill put them in and see what happens. damn teh new regulator is ugly. i think ill go buy another repro looking one to replace it later. funny how i dont care if a car is a stock color or if its modified, but the fact that the regulator isnt original and that the starter solenoid is a D2XX PN are two of the things that really really bug me about my car. damn im strange
 
1 - 5 of 5 Posts
Top