Mercury Cougar Owners banner

1 - 5 of 5 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1 (Edited)
Hey guys. Im a newbie when it comes to transmissions so i need your help diagnosing my tranny issue. The trans fluid is at the correct level and its red. The tranny shifts perfectly from Park to Reverse but it doesnt shift that way when I shift into Drive,1 or 2 gear and when i shift into Drive,1 or 2 gear the car just feels like its in Neutral and wont go. I have to wait until the tranny is all warmed up for at least 5-7 minutes of idle time in order for the tranny to shift perfectly into Drive and be able to go. So guys do I need a tranny rebuild, a new shift kit or something else?

Thanks for your input and its truly appreciate it.
 

·
Registered
Joined
·
1,704 Posts
Worn, cracked or broken forward clutch pack piston seals (aka: morning sickness). Time for a rebuild.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #3
Thanks tbm3fan
Last question, The car is mostly stock so what good reliable rebuild kit would you recommend?
 

·
Registered
Joined
·
11,950 Posts
Transgo kits are pretty common and decent. Also note that you don't get the selector shaft seal with most kits - it's seperate, and you will want to do tht while your in there....cheap and easy at that point. Good luck
 

·
Registered
Joined
·
223 Posts
If your willing to rebuild the trans anyway why not try an old trick and add 2 or 3 ounces of brake fluid to the trans before you go that far. The brake fluid will soften the seals and may very well fix the problem. I have used this method a half dozen times or more over the last 30 years and it works more times than not. If its going to work you will know in a few hundred miles. If it does not work I have never seen it cause bigger problems. Your mileage may very.

Bill
 
1 - 5 of 5 Posts
Top