Mercury Cougar Owners banner

1 - 2 of 2 Posts

·
Premium Member
Joined
·
49 Posts
Discussion Starter #1
I pulled my C4 out of my 67 289 due to the fact that it leaked EVERYWHERE.
While I was going through it, I did a full rebuild with a shift kit from TCI via Summit Racing.

When it was all back in the car, at first try, it always wanted to be in reverse no matter that gear it was in.

Dropped the pan, pulled the valve body out and apart again, all looked well. Put it back together with a helper this time and realized the shift arm in the case was bent and would walk out of the gear selector piston.

Got it all back in place and double checked the linkage stayed in engaged to the valve body in all gears.

Now it has every gear except reverse.

It had a solid lockup when going into drive, but when putting it in reverse, I can hear a clunk, but don't know if that is the band grabbing, or the clutches locking up.

In the valve body, right now when the two halves are apart, the only check ball is the one in the "bathtub".

Everywhere I have read online says the other check ball can be left out to firm up 2nd gear.

Does it sound like I have a simple issue with the check balls, or do I have serious mechanical issues further in? I did all the air checks, and all seemed well before putting the valve body back in .

Does anyone have a 67 specific valve body diagram I could look at for something obviously wrong that I screwed up on reassembly?
 

·
Premium Member
Joined
·
49 Posts
Discussion Starter #2
It was a check ball issue. Got it going forwards and backwards now.

However, now the input shaft seal is leaking.....
 
1 - 2 of 2 Posts
Top