Mercury Cougar Owners banner

1 - 5 of 5 Posts

·
Registered
Joined
·
913 Posts
Discussion Starter #1
Haven't heard what the results were from your starting problem, just wonder what you found ? keep us informed. Towcat:wave:
 

·
Registered
Joined
·
58 Posts
RETURN OF BURGERTIME.

I got a little bit sick and took off what feels like was more than a month.

If my memory serves, the last time I posted, I ripped everything down to the block and put it back together with new gaskets, etc. It didn't change a damn thing. After my hiatus, I decided to replace the timing chain and pop on a new distributor (just because I could). I was able to effortlessly remove the old timing chain with a screwdriver. That guy was STRETCHED.

MYSTERY SOLVED, AND THEN SOME.

I finally got it running yesterday.
Almost every problem I was having before has disappeared. The random stalling, the nasty hissing on startup, the extreme overheating, the sputtering, the engine knocking, the low oil pressure, vacuum issues, gone. All systems are GO. I swear I almost cried when I went on my first test drive. It was beautiful.

Looking back on it, I don't think I had to do as much work as I did (lack of exp, lack of research), but it all feels like it was worth it.

I wonder where to go from here..
 

·
Registered
Joined
·
11,950 Posts
Well, live and learn they say.....probably needed a fair amount anyway. Glad you got 'er fired up now! At least you know what you have now.
 

·
Registered
Joined
·
58 Posts
Yeah, I swear some of this crap looked like it had never been taken apart, never serviced. It's amazing what kind of bs I inherited from the previous owner.
 

·
Registered
Joined
·
7,552 Posts
Congratulations on your success! I know, it is very rewarding when the paper weight moves under it's own power......
 
1 - 5 of 5 Posts
Top