Mercury Cougar Owners banner

1 - 13 of 13 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter #1
I have brake switch problem.I changed my front brakes from drums to dics and i had to change my brake pedal.Now that I have to hook up the switch,my brake lights don't work.I know it has something to do with that little retainer clip and how it is installed(I think).Is there anyone that can help me thanks
 

·
Registered
Joined
·
2,991 Posts
I believe the brakelight switches are different for drum & disc brakes. Which one are you using? Also, what year is your car? John
 

·
Registered
Joined
·
84 Posts
Discussion Starter #3
I am using my old one.I looked at both and they look the same maybe different color spring but what do I know.Do you think thats my problem.I can t get the switch to activate.When the master cyclinder rod is pushed in the switch won t work correctly
 

·
Registered
Joined
·
2,991 Posts
I would try the one for disc brakes and see if that solves your problem. Good luck. John
 

·
Registered
Joined
·
84 Posts
Discussion Starter #5
but my problem is that the switch,when the brakes are aplied there is nothing that pushes on the switch housing to active the brake lights.i will try the other switch but like I said they are identical.
 

·
Registered
Joined
·
1,853 Posts
Do you still have the old pedal? what are the differences between the two? Study that and you might see your problem? Just a thought.
 

·
Registered
Joined
·
2,518 Posts
You do need to use the other switch, I know that. The manual brake switch is stiffer, and has a different mounting point on the pedal that puts more leverage on it to compress. I was sold one of these for my car at one of the big parts houses, I had no brake lights unless you stood on the pedal. I ended up using a good original.
 

·
Registered
Joined
·
84 Posts
Discussion Starter #10
so the spring is stronger on the old one! looking at them the housing looks the same. what presses up against it to active it(that presses down on the spring). I changed my front drums to disc`s but driving it seems the same as when I had manual brakes. Am I missing something!
 

·
Registered
Joined
·
2,518 Posts
Did you add a booster to the setup? If not, then the same switch should work. For some reason I was thinking you were doing a manual to power brake conversion.
 

·
Registered
Joined
·
84 Posts
Discussion Starter #12
is that not what i did. i changed from drums to disc in the front and added a brake booster and master cylinder. Could my problem with the brake not being so agressive be because i bought my booster and master off ebay for $80 NEW. I can't see that but what do I know!
 

·
Registered
Joined
·
84 Posts
Discussion Starter #13
well I found my problem! First problem.....brake lights... Wire harness under the dash was not pluged in all the way!!! Second problem power brakes fell like standard brakes. Fixed......the hose from the booter to the manifold was plugged!!! Well thank you guys for your ideas.
 
1 - 13 of 13 Posts
Top