Mercury Cougar Owners banner

1 - 9 of 9 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
My brake lights are not working but my reverse lights and turn signals work. I was wondering if this was a fuse issue, or an electrical problem. Also..where is the fuse box located on a 68 Yr7 coug? thanks a lot
 

·
Registered
Joined
·
794 Posts
I dont know about the xr7, but on my 67 std. the box is above and to the pass side of your gas pedal. Its a black box with a bunch of glass fuses in it.

Could be a blown fuse. You can pull the fuse to see if the small wire inside is still intact, but the best way to tell is with a voltmeter. I have seen fuses that look good, but do not have continuity.
 

·
Registered
Joined
·
175 Posts
If it's just the brake lights...

there ae two most likely culprits; the fuse or the brake light switch. I'd check the fuse first, if it's good check the switch. they're relatively cheap and easy to get at a local parts store.
 

·
Registered
Joined
·
314 Posts
I had the same problem with my Cat, its probably the brake light switch. The switch is located at the top of the brake pedal arm. It's a cheap part maybe $5 dollars at Autozone.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #5
thanks for the info guys. i found out that the fuse was blown, so i replaced it and it works perfectly. Just in case, what does the brake light switch look like?



ryan
 

·
Registered
Joined
·
175 Posts
It mounts on the pedal arm

up high, almost under the dash. There are two wires going to it.
 

·
Registered
Joined
·
648 Posts
That's what I get for reading these posts...

My brake lights went out this morning!!!

I know, I know - check the fuse and the switch!!! :D
 
1 - 9 of 9 Posts
Top