Mercury Cougar Owners banner

1 - 3 of 3 Posts

·
Registered
Joined
·
720 Posts
Discussion Starter #1 (Edited)
The check valve on my brake booster was bad. The booster has a life time warranty but states if the check valve is removed it voids the warranty. So I ordered a new booster under the warranty. Turns out they can not get just the booster but have to get it with the master cylinder attached. My master cylinder (MC) also has a life time warranty, so the deal was made to replace both under the life time warranty. Since the MC was attached to the booster when I received it I installed booster and MC as a single unit. I bled the MC , than bled each brake, stuck all the vacuum lines on the check valve. Now I have another problem. The pedal feels good going to the floor but when you let off the pedal the return is VERY slow. It takes about 5 seconds for the peddle to come back up and the brakes to disengage.
Did I missing something?<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com<img src=" /><o:p></o:p>
Does this sound like the replacement booster and MC are messed up?<o:p></o:p>
 

·
Registered
Joined
·
11,950 Posts
HUH? Kinda does - I wonder if your problem is the proportioning valve instead? Maybe it's hanging up internally - they are known to get crudded up but good.....
 

·
Registered
Joined
·
316 Posts
Its the proportioning valve or mc for sure , sounds more mc since that is the fresh change . The spool may be sticking and not returning allowing the fluid back in the bowl . You could visually check this with the lid off but you have to push the pedal really slow as not to squirt out of the mc .
 
1 - 3 of 3 Posts
Top