Mercury Cougar Owners banner

1 - 4 of 4 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
Hello All, The choke on my 2100 Autolite Carb. has no piston inside the choke housing. Is this normal? I can not get this choke to operate properly. I have tried all the suggestion here on the forum. When starting the car when it's cold the fast idle does not kick in. I have to feather the throttle to keep it running until warm. Please Help!
 

·
Contributing Member
Joined
·
1,881 Posts
Hello All, The choke on my 2100 Autolite Carb. has no piston inside the choke housing. Is this normal? I can not get this choke to operate properly. I have tried all the suggestion here on the forum. When starting the car when it's cold the fast idle does not kick in. I have to feather the throttle to keep it running until warm. Please Help!
Check this out. http://www.hurtle.com/cars/mustang/fixes/carb/ Look at Step 6 - Choke Adjustments and Step 13 - Cold Idle Speed Adjustment
 

·
Registered
Joined
·
23 Posts
Discussion Starter #3
I have read this article about ten times. Maybe I am missing something. I have tried everything in this article. It shows adjusting the piston with a paper clip. The problem is my carb. does not have a piston to adjust. My main question is, will the choke work without this piston? I can't seem to get an answer to this question. All the pictures I have seen show this piston. The lever inside my carb. doesn't even have a connection point for the piston. I have seen the lever and piston part for sale and they are connected together in one unit. Some one please help!!!!!!
 

·
Registered
Joined
·
1,612 Posts
I read somewhere a while back that Motorcraft versions of the 2100 with electric choke used the older Autolite choke housings without pistons, but I haven't been able to confirm that.
 
1 - 4 of 4 Posts
Top