Mercury Cougar Owners banner

1 - 9 of 9 Posts

·
Registered
Joined
·
300 Posts
Discussion Starter #1
OK,

A while back I had a frozen sequential motor. I fixed that with a new motor. Now, there's no power getting to the motor in the trunk. Hazards work, running lights work and brake lights work.
I checked the link to testing the wires at the plug but the listed colors in the table don't match the harness on MY 67.

I saw that someone had the same exact situation, however he took it to someone and paid $250 to fix it, but didn't list what it was, only that it wasn't the turn signal switch.

so, does anyone know what else it would be aside from the switch? Is there really another relay other than the one that works the hazard lights? If so, WHERE is it? near the glove box? gas pedal with the hazard relay? inside the right front tire???? GRRRRR!!!!

ok, count to 10.... breathe.... he he he he hoo hoo hoo hoo... oh, wait, lemans? no... justtttttttt relaxxxxxxxx...

Anyone?? Anyone???
Robert
 

·
Registered
Joined
·
89 Posts
Im the guy who paid $250 after installing the new switch

I have a 67 as well as the 68 that was acting up.
There is a glass inline fuse its located somewhere between the ignition switch and above the gas pedal, that provides power to the turnsignal switch.
67 was also a split year with the turnsignals. Something to do with a hazard light relay (Early and late production)
Have you visited this website?
http://www.thuntek.net/cougars_unlimited/seqts.htm
I have the 67 turnsignal suplemental manual, its like 70 pages.
Check the fuse first.
Let me know if its good or not.
Dave
 

·
Registered
Joined
·
89 Posts
Oh yeah, there are relays that you can check as well mounted on the firewall above the gas pedal and to the right.
Hope you dont have a console, cause they can be difficult to get to if you do.
D
 

·
Registered
Joined
·
300 Posts
Discussion Starter #4
The inline fuse is good and the relay SEEMS to be ok. I know there's the one that clicks when you turn on the hazard lights...

Now I've seen the cost of the switch and trying to find someone local that has an extra that I can borrow to see if that's what the problem is before I spend the money on it.

Thanks...
Robert
 

·
Registered
Joined
·
89 Posts
Is your 67 the one with the hazard relay in the trunk or is yours the one with the hazard relay built in to the sequence box? '67 had an early and a late set up and the hazard light relay was the difference.
 

·
Registered
Joined
·
89 Posts
I can scan the picture of the schematic where all the relays and switches are from the shop manual suplement if you want. If memory serves me its a 2 sheet scan.
If you want I can scan it and email it to you as an attachment or I can try to post the scaned image here. I dont know what the list serv has as a limit on size attachments tho.
Let me know and I'll be glad to send you what I can.
David
 

·
Registered
Joined
·
300 Posts
Discussion Starter #7
uhm, well when the hazards are on, I hear the clicking under the dash...

but either way, yeah I'd like that scan if you have it handy.

send it to [email protected] when you get a chance..

Thanks,
Robert
 
1 - 9 of 9 Posts
Top