Mercury Cougar Owners banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2,867 Posts
Discussion Starter #1
Hi all,

Newbie alert! But I've ALREADY gotten LOTS of info from y'all, and you didn't even know it! Ahhhh...the life of a lurker...

However, I am somewhat disappointed that y'all haven't address this issue, so I am forced to show my digitally-enhanced "face" and ask ya outright.

I have a '67 Coug (Dan Gurney Special, according to Mr. Marti, but alas, no sign of it as such looking at it), that USED to have heating problems in the original 302 that was in it (yeah, yeah, yeah...I know...the guy that I got it from yanked the 351C out of it and installed the 302).

ANYHoooo...I rebuilt the 302, and put a 4-row radiator in it (hey, the cruise at Hot August Nights really can wreak havoc on a 2-row with A/C). I also put a flex fan on it (17") after losing a belt and bending the hell out of the 7-blade original fan that was on it. :cry:

My question is this - I have had nothing but problems with clearance between the fan and the shroud since I got the 7-blade bent. I have gone through 3 shrouds so far.

I keep seeing shrouds for the 20" radiators advertised as "non-A/C" or "A/C" - what's the difference? Could it be that I keep putting NON-A/C shrouds on my baby, and that's why the fans keep rubbing? (this happens mostly under load, torque-tweaks seem to do it - but both motor mounts are new and in great condition).

Anyone else having such problems? I wonder if I should just try to find a new 7-blade and go back to the clutch fan...but I just don't know why my current setup won't work...

Thanks all, hope to be a frequent contributor! GREAT site!!!
Paul Danielson
 

·
Premium Member
Joined
·
5,758 Posts
Paul,
why not try n go for a electric fan setup. or unless you wanna go original? If originality isnt to much of a concern you can eliminate the fan assembly completlt n pick up some extra horses by this swap.But look into a clutch fan part where the length is alittle bit shorter.But see if that may work.
thanks
pat
 

·
Registered
Joined
·
2,867 Posts
Discussion Starter #3
I guess I forgot to provide a few details *LOL*

I actually DID have the shorter shaft on the clutch fan when I had it on there - and I didn't EVER have any problems with that fan until the belt broke and bent the blades - I could never get them bent straight again, I guess - I've been bustin' out the shrouds since then...*sigh*

I might consider the electric fan...would that be a pusher or puller??? I have never used them, and actually heard they don't do as good a job as a flex or original fan - have I been led astray by the rumor mill??? Any recommendations for a good one?

Also , do you leave the shroud on when you use an electric one?

also, do any of the rest of you have opinions either way?

I like to stay original where I can, but don't let that deprive me of reliability or fun - got a non-ford posi in it, and it's bright yellow (I guess I should add a pic!), mags, and a MSD ignition, along with a complete buildup on the engine when I rebuilt it...so I do what I need to do to make it reliable and fun.

THanks!!!
Paul
 

Attachments

·
Registered
Joined
·
3,153 Posts
That's a beautiful cat Paul. I've had clutch fans, flex fans and electric puller fans. Never had a problem with any of them. You wouldn't use the stock shroud with an electric fan. Also I think I know what your problem is. You can NOT repair bent fans, you will never get the balance right. So, replace your fan and you should have no more problems.. And finally, welcome to the forums, this is a great place, hope you enjoy it here...

Bruce
 

·
Registered
Joined
·
2,867 Posts
Discussion Starter #5
Thanks Bruce (for the compliment AND the info!),

I've pretty much gone through the whole thing actually the only think left is the upholstery and the power steering (which I'm workin' on now - thanks again to this forum - I'm gonna put the 390 setup on it (under the crossmember) so that I quit burnin' holes in my pressure hoses on the Hi-Po exhaust manifolds *shaking head* - *L* I suppose I should put up a "before" pic of my basketcase-turned-baby...

Yeah, I figured that about the bent fan - I kinda considered an electric, but ended up going for the flex fan - and keep the shroud - just because I like the little "caution" sticker on the shroud *LOL*

I suppose the reason the flex fan keep hitting is that the spacer I use is a tad too long - it looks to be about an inch and a half or so...I might try a shorter one...does anyone know where the best place for fan to sit is? I figured about half IN the shroud and half OUT of it - which is where it is now, but like I said, it rubs on the bottom of the shroud.

Anyway, thanks for the welcome and the responses, guys!
 

·
Registered
Joined
·
3,153 Posts
Hey I just thought of something, did you check the trans mount?? Also, dodn't feel too bad about the 351C, it was not the original engine... check the trans mount..

And post more pictures!!
Bruce
 

·
Registered
Joined
·
2,867 Posts
Discussion Starter #7
I'll check the trans mount - but that hasn't changed from the "time before" the string of broken shrouds (and hearts) began...so I wouldn't expect that to be the problem - but hey, I've said "I wouldn't expect..." before...*L*
 
1 - 7 of 7 Posts
Top