Mercury Cougar Owners banner

661 - 679 of 679 Posts

·
Registered
Joined
·
133 Posts
upgrade the blocker rings, i did to the Carbon fiber ones.

did you dial in the bellhousing also?
Lol! I didn't do the build this time. I sent the car to Schwartz Performance and they did a complete build for me. The problem is with the driver (me). Lol. I just need to get some seat time in it.
 

·
Premium Member
Joined
·
13,577 Posts
Erik,

On a good day, I am in the 12's ([email protected] best so far) on street tires. Keep in mind that this is in an over 4000 lb car with me in it, considerably more than a hardtop.
 
  • Like
Reactions: SEVENLITER66

·
Registered
Joined
·
133 Posts
wow that is quite the extra weight, my car weighed 3200 on the scales. that vert top made out of lead?
I imagine the extra weight is from the substructure bracing for the lack of a roof? Mine weighed in at 3600# with full chassis, aluminum motor, and trans.
 

·
Registered
Joined
·
599 Posts
Discussion Starter #670
I am annoyed at my gauge lights, i have checked (with another) the headlight switch and that is fine. My turn signals work, and the interior lights work when i turn the switch all the way. What is the next part to check, the printed circuit or something else?
 

·
Premium Member
Joined
·
13,577 Posts
Erik,

Besides being annoyed with your gauge lights, what (exactly) is the problem with them? Some work, none work, what?
 

·
Premium Member
Joined
·
13,577 Posts
Hmmm, if none work, that would suggest a problem with the supply, unless all the sockets at once are not contacting the printed circuit properly. Using the wiring diagram, you'll need to check for this supply at the headlight switch and then at the PC connector at the cluster, etc. You might remove one bulb/socket at the cluster and just make sure that there is not voltage at the contacts before you do the former. Unfortunately, neither is an overly pleasant task!
 

·
Registered
Joined
·
599 Posts
Discussion Starter #674
some new safety items added to the car!



sittin pretty



thoughts on this? it isnt installed yet, is it the color that im not digging, something just seems strange?
 

·
Registered
Joined
·
133 Posts
Was wondering where you disappeared to
 

·
Registered
Joined
·
599 Posts
Discussion Starter #677
Was wondering where you disappeared to
just super busy, kids, work, business, travel, and now auto-x season. Getting the cougars feet wet this year in the cone bashing!

I am having an issue the Rod and Custom 4 link i have does not want to let me install their swaybar, it is like the bar just is not wide enough, kind of important in auto-x. I sent them a message about it waiting on their response. Not sure why I didnt try and install years ago...
 

·
Registered
Joined
·
10 Posts
I love this site. I have learned so much new about cars here. Especially I like real-life photos from the car owners and their descriptions of various details. I am from China https://populationstat.com/china/, but from a small town. And unfortunately, I have never seen some car models in real life. It is good to have such feedback here as you can literally study everything in detail.
 
661 - 679 of 679 Posts
Top