Mercury Cougar Owners banner

601 - 620 of 679 Posts

·
Premium Member
Joined
·
4,111 Posts

·
Premium Member
Joined
·
13,577 Posts
Does sounds really good Erik! Does it run on pump premium?
 

·
Registered
Joined
·
599 Posts
Discussion Starter #604
Does sounds really good Erik! Does it run on pump premium?
yeah i run 93 in her, about 10.25:1 compression if i remember correctly. Things i am planning here soon. Efi dyno tunes, new dizzy installed for timing control, a few 1/4 mile runs, maybe a test and tune auto cross, and really just enjoy the car. I entered the car into a car show on May 7th .

I wish i could go to the 50th show, but the wife will be 8 months pregnant and with our past pregnancies I better not go anywhere 4+ hours away.
 

·
Premium Member
Joined
·
5,758 Posts
Looking good eric,

have you installed the headliner yet? I seen the video of the interior installed but noticed the headliner out. Are you going to install dynamat under the roof prior to the headliner??

thanks
pat
 

·
Registered
Joined
·
599 Posts
Discussion Starter #606
Looking good eric,

have you installed the headliner yet? I seen the video of the interior installed but noticed the headliner out. Are you going to install dynamat under the roof prior to the headliner??

thanks
pat
Pat,

I have not get to the headliner yet, as of this morning I was talking with my interior guy about doing it for me, covering the speaker panel, and c pillars. I don't plan on doing dynamat on the roof, I don't have any noise I can tell from it.
 

·
Premium Member
Joined
·
13,577 Posts
Is there a way to bench test the lights/fuel gauge on the gauge cluster to see what the issue might be?
Not really. But, you haven't said what the issue is!
 

·
Registered
Joined
·
599 Posts
Discussion Starter #609
Not really. But, you haven't said what the issue is!
Issue is no back lighting, only one turn signal blinks on dash, no high beam indicator, gas gauge stopped (was working) those are the only things I really need on the gauge pod. Tach and Speedo working but they are hooked up differently than the others.
 

·
Premium Member
Joined
·
13,577 Posts
No backlighting, assume you tried turning the headlight switch (it is a dimmer function)? It also could be a bad headlight switch (if you have a spare to try, unplug the switch in place and try the spare hanging down, not mounted). All your 194 bulbs good in the cluster? Sometimes the 194 sockets don't make contact. Printed circuit have any lifting traces? If yes, replace it. Gas gauge could be related to the last question as well.
 

·
Registered
Joined
·
599 Posts
Discussion Starter #611
No backlighting, assume you tried turning the headlight switch (it is a dimmer function)? It also could be a bad headlight switch (if you have a spare to try, unplug the switch in place and try the spare hanging down, not mounted). All your 194 bulbs good in the cluster? Sometimes the 194 sockets don't make contact. Printed circuit have any lifting traces? If yes, replace it. Gas gauge could be related to the last question as well.
tried the headlight switch, and not difference, are the bulbs like a christmas light where one goes out they all go out? I was about to order a new circuit and regulator but wanted to check everything else before i spent another $130 for a $1 bulb... thanks for the reply bob!
 

·
Registered
Joined
·
599 Posts
Discussion Starter #613
well this is embarrassing i pulled the dash and gauge cluster to find that the cluster was not plugged in, I guess the last time i messed with it i didnt connect it correctly and it fell out.



the dash lights still are not working, I guess I will try my headlight switch again since the past test is null and void now!
 

·
Registered
Joined
·
599 Posts
Discussion Starter #614


didnt place in the show i went to, still no headliner, sail panels or package tray covered. car wasnt the cleanest either, but there were some really nice cars 400+ at this show.
 

·
Registered
Joined
·
599 Posts
Discussion Starter #620
driving about 1500 miles total on the build, a few things I have noticed.

1. Brakes need more vacuum or switch to manual
2. the suspension is good actually really good, but I need to stiffen up some of the body roll with a upper in the engine bay support
3. exhaust is a little loud cruising
4. EFI is awesome
5. I may have a small vacuum leak, still cant find it
6. The car is a head turner for sure
7. The car brings out peoples emotions and everyone wants to tell you their story about their other car, or a cougar they once had
8. 440whp is awesome
9. a track day will be needed sometime soon
10. I would do it again, but maybe a little different in areas. such as final drive ratio, rear end gear, axel spline #, and seat belts (really hate the stock ones)
 
601 - 620 of 679 Posts
Top