Mercury Cougar Owners banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 69 cougar with 351 windsor, and the the original 2bbl carb. The problem is everytime i rev it too high, or put a load on the engine in gear, it will backfire out the carb, and stall the engine. The firing order is right, the points and condenser are new, the dwell is at 29deg, and the ignition is at 12 advanced, and the idle speed is 600 rpm. The carb is unchanged as far as I know. Im running out of places to look to find the answer, and everyone i ask has conflicting opinions. I hate to start tearing the motor apart when the problem is something stupid. Any tips or advice will be well appreciated.
 

·
Registered
Joined
·
5,299 Posts
how does it idle?? you might have a burnt valve... a guy i knew had the same problem with his 68 Impala. turned out to be a bent pushrod and a bad lifter. might want to give that a shot. ive been working on this Stang of a buddy of mines and it is just running like crap. very rough at idle, but it seems to smooth out when it revs. weve settled on a bad lifter and thats along with opinions of others as well. its really not THAT hard to change, just time consuming. if itss a burnt valve, well, it will give you an excuse to put a new caam in as long as there is some down time right?? he he. oh yeah, welcome aboard.
 

·
Registered
Joined
·
2,145 Posts
my old stang started doing that, it turned out to be slack in the timing chain. i put on a all steel cam gear and a new chain and it ran normal again.
 

·
Registered
Joined
·
118 Posts
try this

i have a 69 351w 2v, i just lately changed the gears and timing chain and the car idled rough and when i gave it gas it would stall out or backfire thru the carb. i did all the things that you did, but the final fix i disconnected the vaccum advance on the distributor and it ran just great, i found out that the diafram on the distributor was bad. i also had the line from the carb to the distributor in the wrong place.;)
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
thanks

Thanks for all the advice, im going to give it a try, and hope I can get it all sorted out, I need to get out and cruise!!
 
1 - 5 of 5 Posts
Top