Mercury Cougar Owners banner

1 - 8 of 8 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
Its been a while since i got on here. but I have replaced my TS switch and the changed the sequential box to digital. now my turn signals work fine. but now when i want to turn right my left brake light is on and the same for the other side. what could be wrong here?? my TS switch wiring is exactly like the diagram off of Cougars unlimited. help me.
 

·
Registered
Joined
·
7,552 Posts
When exactly does it do this? Whenever you use the turn signal?
 

·
Registered
Joined
·
7,552 Posts
So, it sounds like, your brake lights come on, everytime you make a turn, regardless, of actual foot on brakes....Is that correct?
 

·
Registered
Joined
·
45 Posts
Discussion Starter #5
Yes.. sorry for the confusion. I can have the brake switch disconected and they still come on everytime I use the turn signal..I replaced brake switch also but still the same thing..
 

·
Registered
Joined
·
7,552 Posts
In 68, is there a white plastic connector, that holds all the wires from the TS switch, and connects with the main wiring harness? I know that when I did my 68, I had to swap out the connector. It sounds to me like you have a wire out of position either into, or out of that connector.
Hopefully some one else will chime in and confirm or deny my diagnosis...
 

·
Registered
Joined
·
45 Posts
Discussion Starter #7
I have it wired exactly how it says on cougars unlimited.. but out of frustration.. I just cut the green and white wire in the back and wired it to the brake switch directly. It seemed to fixed the problem for now..
 

·
Registered
Joined
·
45 Posts
Discussion Starter #8
I have found the problem.. Some how my wires melted together behind the rear quarter window regulater. So now i need a new harness from my tail lights to my dash driver side. So there is my problem. :(
 
1 - 8 of 8 Posts
Top