Mercury Cougar Owners banner

1 - 5 of 5 Posts

·
Registered
Joined
·
270 Posts
Discussion Starter #1 (Edited)
67 Charging Issue

My 67 XR7 is not charging and I can't seem to narrow it down. Over the winter, I pulled the motor/trans and painted the engine compartment, engine, etc. When I reinstalled them, I had the no start isssue. Turned out to be the ns switch. When I got it running, it's only reading between 11.5 and 12.2 volts. I had the rebuilt alt and battery tested at Advance. Both were fine. Purchased a mechanical voltage regulator at Napa. I have all new cables, new braided ground on the back, another heavy ground cable from the block to the shock tower. Added a high torque starter, and a B/W solenoid. When I did the work, I had bare metal using star washers. I'm pretty sure all the grounds are good.

I unplugged harnesses one at a time, radio, steering column, pulled the fuses, etc. No change.

Before doing the work it was charging. The stock wiring is all intact, not hacked.

Any thoughts what to look at next? I'm stumped. What's the best, newb friendly wiring diagram to buy? I have the blue factory shop manual, not much help.

Thanks in advance
 

·
Registered
Joined
·
89 Posts
I had the same problem last week. I found that one of the ring terminal on the alt. was loose and broken from the wire.
 

·
Registered
Joined
·
11,950 Posts
HUH? Dang - you have tried everything reasonably possible from what I can think of? Any chance you could swap your regulator into a known good car to verify it?....That's about the only thing I can think of - grasping at straws though? Boy IDK...maybe even try your alt in another car? SOunds kinda like something is pulling it down under a load - reg/alt...?
 

·
Registered
Joined
·
270 Posts
Discussion Starter #5
I had the alt tested at Advance (for what it's worth). I don't have another car here to try it on. The regulator is doing the same as the other one, not sure that's the problem. Doesn't seem to be a draw when it's running or parked. Putting the meter on it while turned off there's no draw.

Thanks for the suggestions, please keep em coming
 
1 - 5 of 5 Posts
Top