Mercury Cougar Owners banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
13,577 Posts
Discussion Starter #1 (Edited)
Just accidentally burned up the printed circuit on my cluster. :newburn: Looks like the repros (what I really want) are out of stock. I will call and see what the ETA is tomorrow but was wondering if anyone has a spare they would be willing to part with. Please PM with price with shipping to 08724.

Thanks,

Bob
 

·
Premium Member
Joined
·
13,577 Posts
Discussion Starter #3
Thanks Lew, but that is for a standard. WCCC has a couple of ebay listings for the correct part, but their website will not let you order it (so one or the other is wrong) and MU looks like they are out of stock with no back in stock date.
 

·
Premium Member
Joined
·
1,727 Posts
Bob
I have two
one is marked c9wf-10c956-a says xr7 on the box in writing so Im not forsure.

then another one in a ford nos box marked c9wy-10k843-d unopened.
John
 

·
Premium Member
Joined
·
13,577 Posts
Discussion Starter #5
Bob
I have two
one is marked c9wf-10c956-a says xr7 on the box in writing so Im not forsure.

then another one in a ford nos box marked c9wy-10k843-d unopened.
John
Hi John,

I have a repro on the way to me, but thanks. I looked up the part numbers you provided and they both seem to be Red printed circuits, I need Blue.
 

·
Registered
Joined
·
130 Posts
I have my cluster out to do maintenance, I am hoping to avoid burning mine out as you did. Can I leave the battery disconnected and replug in the connectors? This should be good to go, right?

What happened to yours?

J
 

·
Premium Member
Joined
·
13,577 Posts
Discussion Starter #7 (Edited)
I have my cluster out to do maintenance, I am hoping to avoid burning mine out as you did. Can I leave the battery disconnected and replug in the connectors? This should be good to go, right?

What happened to yours?

J
Never a bad Idea to disconnect the battery. What happened to mine was (unbenounced to me) some of the connector fingers on the PC had come loose and were crossed to others. When I plugged in the connector, POOF! These are famous for delamination and the more they are handled, the worse they become. Mine was good to start, but two or three cluster removals and not so much! Glad I am getting a repro as I have had quite enough of this nonsense!
 
1 - 8 of 8 Posts
Top