Engine Running Hot
Results 1 to 12 of 12

Thread: Engine Running Hot

  1. #1

    Engine Running Hot

    I have a 68 RX7 302 that I inherited and it continues to run hot and develops vapor lock. I am not a gearhead by any stretch but have tried a few things either on my own or taken to shop and have done. I have installed a 4 core radiator and fan shroud, rebuilt the transmission, installed a Pertronix ignition, changed plugs, adjusted the timing numerous times, check for head gasket leak by testing for hydrocarbons in radiator, had the carb rebuilt (2-barrel), and a new timing belt installed. The previous owner took meticulous care and kept log of everything that was ever done to the car (including each and every oil change, battery charge, air in tires, etc.). Engine was rebuilt in 1991 (169,000 miles) to factory specs including rebore block (+.030"), grind cruuck (can't quite read writing in log book) (-.010"), new cam shafts and bearings, new hydraulic lifters, piston rings and bearings. I am at a lost what to do next. Any suggestions would be much appreciated. Thanks
    Rich

  2. #2
    Hi. When you say running hot do you mean the water temperature getting Into the red forcing you to pull over? Or is your symptom only vapor lock?

    If the engine is truly over heating it might be an issue with the water pump. What type of fan are you running? 7 blade from a Big Block with clutch? Aftermarket? Also I have read that it is easy to place the head gasket on backwards which blocks one of the water jackets that flows liquid from block to head. Hope that isn't the case.

    If vapor lock is the only concern that you can focus on getting heat out of the carb and fuel lines that sit above the intake manifold. There are heat shields, spacers etc... but I don't have experience to know if any of them work as advertised.

    Good Luck!

    John (Gaugster)

  3. #3
    Join Date
    Mar 2002
    Location
    Dallas, Tx
    Age
    62
    Posts
    10,925

    Re: Engine Running Hot

    Vapor lock is not typically a problem caused by overheating. It really is indicating a fuel delivery problem. In the past the only times that I have had this problem it is not caused by vapor lock, yet the symptoms are similar because the car won't start. In my experience this has always been caused by rust or dirt in the tank or fuel lines. The fix is usually replacing the gas tank and sending unit, and the fuel line from the back of the car to the front.
    Royce Peterson
    CCOA MEMBER #590
    1968 GT-E 427 XR-7 Augusta Green / Saddle It looks all stock Heh - Heh
    1968 XR-7 428CJ Ram Air Red / Black / Black C6
    1910 Model T Ford Touring Red/ / Black
    1914 Model T Ford touring Maroon / Black
    1915 Ford Model "T" Touring.....Black / Black (of course)
    1917 Ford Model T Roadster Green / Black
    XR7-G Registrar
    CURBSTER Hidden Content

  4. Remove Advertisements
    MercuryCougar.net
    Advertisements
     

  5. #4

    Re: Engine Running Hot

    Thanks for the responses. The car sat in a garage for a couple of years and I had the gas tank drained along with the trans, brake, and coolant . The temp gauge goes past halfway when running on hotter (>75) days after driving city traffic for 20-30 minutes.I have replaced the water pump and fuel filter. The fan is the factory fan blade. I will take a closer look at the fuel lines. I had noticed that the fuel in the fuel filter bubbled like it was boiling. I had thought about a spacer for the carb also but my thinking was that since it did not come with a spacer why should it need one now? Again, I am limited in my engine knowledge I have been thinking of a 4 barrel since the gas mileage is pretty lousy. Thanks again for all the tips/suggestions. I will look into everything you have suggested.

  6. #5
    Join Date
    Mar 2002
    Location
    Dallas, Tx
    Age
    62
    Posts
    10,925

    Re: Engine Running Hot

    The '68 302 came stock with a 1" aluminum spacer between the manifold and the carburetor. Like this one:

    https://www.npdlink.com/product/spac...1968&year=1968
    Royce Peterson
    CCOA MEMBER #590
    1968 GT-E 427 XR-7 Augusta Green / Saddle It looks all stock Heh - Heh
    1968 XR-7 428CJ Ram Air Red / Black / Black C6
    1910 Model T Ford Touring Red/ / Black
    1914 Model T Ford touring Maroon / Black
    1915 Ford Model "T" Touring.....Black / Black (of course)
    1917 Ford Model T Roadster Green / Black
    XR7-G Registrar
    CURBSTER Hidden Content

  7. #6

    Re: Engine Running Hot

    Thanks, I'll give it a try

  8. #7
    Join Date
    Mar 2002
    Location
    Dallas, Tx
    Age
    62
    Posts
    10,925

    Re: Engine Running Hot

    Also be sure that you don't over fill the radiator. It needs to be about 1 1/2" below the radiator cap. That way the coolant can expand when it gets hot without spitting out.
    Royce Peterson
    CCOA MEMBER #590
    1968 GT-E 427 XR-7 Augusta Green / Saddle It looks all stock Heh - Heh
    1968 XR-7 428CJ Ram Air Red / Black / Black C6
    1910 Model T Ford Touring Red/ / Black
    1914 Model T Ford touring Maroon / Black
    1915 Ford Model "T" Touring.....Black / Black (of course)
    1917 Ford Model T Roadster Green / Black
    XR7-G Registrar
    CURBSTER Hidden Content

  9. #8

    Re: Engine Running Hot

    Would incorrect timing also be a contributor to overheating?
    Does the engine also continue to run for a moment when you turn the key off?
    Cougar - Not the meanest animal in the woods but it is the baddest cat on the street.
    (69 'vert)

  10. #9
    Join Date
    Sep 2013
    Location
    ND USA
    Age
    55
    Posts
    2,019

    Re: Engine Running Hot

    Factory temp gauges were not vert accurate when these cars were new.. You really should invest in a high quality aftermarket gauge so you know the true temperature your motor is running.... sounds to me like you have a vapor lock problem not a engine over heating issue ..

  11. #10
    Join Date
    Mar 2002
    Location
    Dallas, Tx
    Age
    62
    Posts
    10,925

    Re: Engine Running Hot

    Yes it is the most common cause of overheating, other than missing fan shroud or bad radiators. It's zero cost to check it and set it properly if you know how. You will need the factory shop manual to get all the pertinent facts.

    The car running on after you shut the key off is a classic symptom of timing set improperly. It is normally caused by using fuel that is too low in octane, then retarding the spark to compensate for the loud pinging caused by using crummy fuel. When you back the timing off, the car won't idle, so someone turns the idle screw in to open the carburetor more. The incorrect timing creates hot spots in the engine, particularly the exhaust valves, which will glow red hot. The red hot valves become a source of ignition when the key is off.



    Quote Originally Posted by Double E View Post
    Would incorrect timing also be a contributor to overheating?
    Does the engine also continue to run for a moment when you turn the key off?
    Royce Peterson
    CCOA MEMBER #590
    1968 GT-E 427 XR-7 Augusta Green / Saddle It looks all stock Heh - Heh
    1968 XR-7 428CJ Ram Air Red / Black / Black C6
    1910 Model T Ford Touring Red/ / Black
    1914 Model T Ford touring Maroon / Black
    1915 Ford Model "T" Touring.....Black / Black (of course)
    1917 Ford Model T Roadster Green / Black
    XR7-G Registrar
    CURBSTER Hidden Content

  12. #11
    If you figure it out let me know, my 67 is doing the same thing. Temp gauge after driving a while will creep up to about 3/4, when I shut it off I can hear the fuel in carb bubbling. I’ve put a 1” spacer on 4bl carb, have newer large radiator, new coolant, new clutch fan, new shroud, timing is good, new high flow water pump, new thermostat, new radiator cap and I’m probably forgetting other stuff I’ve replaced but still runs too hot. Head gasket look like they are on the right way so the only other thing I’m thinking is the engine has lots of buildup junk in the water passages, heard of others having that problem. So I’ll update when I pull it and inspect, meanwhile I’m building my 302 roller motor for the car.

  13. Re: Engine Running Hot

    Some very good answers here and gives you a lot to think about. You say that the car overheats but fail to say if it boils the water out of the radiator or not. Do not assume that you have an overheat problem just by the gauge. The cooling system that came originally on your car was adequate but sometimes over the years people change things that they shouldn't. Have you checked the thermostat? You do not want the water to flow to quickly through the radiator as it will not spend the proper time in the radiator to dissipate the heat. What is in the radiator? The proper mix of water and anti-freeze will raise the boiling point and help. Is the radiator cap good, have a good seal and hold pressure. You need the pressure to help raise the boiling point. Does the air flow through the radiator not around it (i.e. any air dampers in place). I will guess that the block is clean seeing that the engine was rebuilt. Cooling systems can be a pain. Take the entire system into your thought process. Good luck with it and keep everyone posted.

    Ron

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Bookmarks

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •